Machine operating systems only support certain versions of FileMaker Pro or FileMaker Server. The version of FileMaker Server or FileMaker Pro that is installed will also determine the minimum version of the FileMaker software present on the network. ie. If the operating system of the server is upgraded, most likely a new version of FileMaker Server will be required, which in turn only supports a certain version of FileMaker Pro on the client machines.

Server - Client Compatibility

FileMaker Server 16

Requires FileMaker Pro 14 - 18 to be installed on the client machines.

FileMaker Server 18

Requires FileMaker Pro 16 - 19 to be installed on the client machines.

Operating System requirements:

  • Windows Server 2012 R2

  • Windows Server 2016

  • macOS Catalina 10.15

  • macOS Mojave 10.14

  • macOS High Sierra 10.13

FileMaker Server 19

Requires FileMaker Pro 18 - 19 to be installed on the client machines.

FileMaker Pro 19 (client) requires FileMaker Server 18 or 19.

Operating System requirements:

  • Windows Server 2016

  • Windows Server 2019

  • macOS Big Sur 11.0

  • macOS Catalina 10.15

  • macOS Mojave 10.14

Client - macOS Compatibility

FileMaker Pro 14 - 16

  • macOS Mavericks 10.9

  • macOS Yosemite 10.10

  • macOS El Capitan 10.11

  • macOS Sierra 10.12

  • High Sierra 10.13

FileMaker Pro 19

Mojave (10.14) or newer

Which in effect means:

  • MacBook: Early 2015 or newer

  • MacBook Air: Mid 2012 or newer

  • MacBook Pro: Mid 2012 or newer, Retina display not needed

  • Mac Mini: Late 2012 or newer

  • iMac: Late 2012 or newer

  • iMac Pro

  • Mac Pro: Late 2013 or newer; Mid 2010 or Mid 2012 models require a Metal-capable GPU[12]

Anyone needing to run anything older than those machines should NOT upgrade, and may not be able to use newer computers / macOS because FM16 is not supported. A new version of Reactor plugin (v6) must be installed.

Catalina (macOS 10.15)

Requires FileMaker Pro 18 and 19. FileMaker Pro 18 can connect to FileMaker Server 16

Big Sur (macOS 11.1)

Requires FileMaker Pro 19 which requires FileMaker Server 18 or 19

New Apple Silicon Macs (M1)

FileMaker Pro 19 is officially supported and works great, though not native yet.

Reactor v6 works in both calendar and task chart (Gantt) versions in our somewhat limited testing.

Reactor Compatibility

Reactor v6 is needed for FileMaker Pro 19, and should be used even under FileMaker Pro 16 if you’re running a recent Mac / macOS (roughly 2017 onwards).


More Information

FileMaker Server Host and client compatibility chart (v14 - 19) https://support.claris.com/s/article/FileMaker-Server-host-and-client-compatibility-chart-1503693079953?language=en_US

FileMaker Pro OS compatibility article here - https://support.claris.com/s/article/FileMaker-Pro-operating-system-requirements-all-versions-1503692917754?language=en_US

FileMaker Server compatibility article here - https://support.claris.com/s/answerview?anum=5677&language=en_US

Did this answer your question?