We have had many reports of earlier versions (< 15) of FileMaker Pro crashing after the 10.14 Mojave update. Officially, only FileMaker Pro 16.0.4 is compatible however FileMaker Pro 15.0.4 also works as expected.

Our advice is to be cautious and plan before updating.

It is possible you'll need to upgrade Streamtime, FileMaker Pro and FileMaker Server before you can move to Mojave.

However, there are some important considerations!

  • FileMaker Pro 15 and 16 only work correctly with Streamtime 14.0v3 and higher.
  • FileMaker Pro 15 does not work with FileMaker Server 12 or FileMaker Server 13
  • FileMaker Pro 16 doesn't work with FileMaker Server 12 or FileMaker Server 13

So if you're keen on moving to Mojave, you'll need to check all these parameters:
Streamtime are you on?

  • Streamtime 14.0v3 or higher
  • FileMaker Pro 15 or FileMaker Pro 16
  • FileMaker Server 15 minimum
  • The operating system of your server machine will also need to be considered. Supported operating systems for FileMaker Server 16 are:

Hardware requirements:

If in doubt, or if you require FileMaker installers please contact support@streamtime.net

Did this answer your question?