There have been several reports of FileMaker Pro crashing on High Sierra. Officially,  FileMaker Pro 15.0.3 and 16.0.2 are compatible, however this does not seem to be the case fully.

Our advise is to be cautious: hold off on the upgrade.

It is possible you'll need to upgrade Streamtime, FileMaker Pro and FileMaker Server before you can move to High Sierra.
However, there are some important considerations!

  • FileMaker Pro 15 and FileMaker Pro 16 only work correctly with Streamtime 14.0v3 and higher.
  • It takes Streamtime 14.0v3 to be compatible with OSX 10.11 (El Capitan) or higher
  • FileMaker Pro 15 doesn't work file FileMaker Server 12
  • FileMaker Pro 16 doesn't work with FileMaker Server 12 or FileMaker Server 13

So if you're keen on moving to High Sierra, you'll need to check all these parameters:
Streamtime are you on?

  • Streamtime 14.0v3 or higher
  • FileMaker Pro 15 or FileMaker Pro 16
  • FileMaker Server 13 minimum, preferably higher.

If in doubt, please contact support@streamtime.net

Did this answer your question?